Kategorien
Uncategorized

The FIP-FS „Microsoft“ Scan Engine failed to load“.

Sonntag, 02. Januar 2022, 15:50 Uhr:
WhatsApp-Sprachnachricht eines Kollegen „Mail funktioniert nicht …“

Gute Güte – das hat doch wohl Zeit bis Montagmorgen! Es ist Sonntagnachmittag und ich bin gerade damit beschäftigt, Petzolds Menuett in G-Dur so auf einem Klavier zu spielen, dass es nach Menuett klingt. Tja … musizieren funktioniert allerdings nur mit 100 Prozent Konzentration – und rund 20 Prozent des Gehirns gehen schon der Frage nach, warum der Exchange-Server nicht das tut, was er soll. Also Noten weglegen und Laptop einschalten.

Check 1: Anmeldung über OWA. Funktioniert ohne jedes Problem; das Postfach öffnet sich in der gewohnten Ansicht. Testmail an den Ehemann wird gesendet. Und kommt nicht an … ebenso wenig wie die Testmail in der anderen Richtung.

Check 2: Anmeldung im Firmennetzwerk. Funktioniert ohne Problem. Das Mail-Protokoll auf der Firewall enthält keinerlei Besonderheiten. Besagte Testmail des Ehemanns wird als „zugestellt“ protokolliert. Über Outlook eine Testmail intern gesendet – kommt genauso wenig an wie bei einem externen Empfänger.

Check 3: Anmeldung am Exchange-Server. Funktioniert ohne Probleme. Auf der Festplatte sind noch 100 GB freier Speicherplatz vorhanden, alle Dienste sind ordnungsgemäß gestartet, die Exchange-Verwaltungskonsole bietet auf die Schnelle auch keine hilfreichen Erkenntnisse.

Okay – langsam wird es spannend! Firewall, Exchange-Server und Outlook scheinen einwandfrei zu funktionieren, aber es werden keine Mails gesendet und empfangen … die innere Stimme sagt, dass ein Neustarten des Servers nicht helfen wird.

Check 4: Blick ins Ereignisprotokoll. Ungeliebt, aber tatsächlich manchmal hilfreich. Zahlreiche Einträge wie „Microsoft-Filterverwaltungsdienst wurde unerwartet beendet“ und „The FIP-FS „Microsoft“ Scan Engine failed to load“.

Aha … mal sehen, was Google dazu sagt …

Und tatsächlich, es gibt bereits hilfreiche Artikel zu diesem Thema, obwohl das Problem noch sehr neu ist. In Kurzfassung: man muss den Antimalware-Scan deaktivieren, weil der Wert für das Datum 01.01.2022 zu groß ist, um ihn in ein bestimmtes Feld zu schreiben. Dabei geht es noch nicht mal um das Datum als solches, sondern um die Versionsnummer, die standardmäßig mit dem Datum beginnt …

Das funktioniert mit dem Exchange-Management-Shell-Befehl
& $env:ExchangeInstallPath\Scripts\Disable-AntimalwareScanning.ps1
Anschließend noch einmal den Exchange-Transportdienst neu starten.

Eine schöne Langfassung des Problems samt Lösung findet man zum Beispiel hier:
https://www.henning-uhle.eu/informatik/the-fip-fs-microsoft-scan-engine-failed-to-load


Sonntag, 02.01.2022, 16:55 Uhr:
Testmail des Ehemanns kommt an … und das Menuett klappt sicher auch irgendwann 😊



Update 03.01.2022
Microsoft veröffentlicht ein Skript, welches das Problem mit der Versionsnummer behebt und somit kann der Antimalware-Scan wieder aktiviert werden.